Не работает проводной интернет на Ubuntu 18.04 провайдер Чайка.Net



  • Приветствую всех жителей форума, а также администраторов, и просто прохожих 😉
    Поставил Ubuntu 18.04 rus с нуля, пока второй системой
    НУ ни как не могу подключить интернет, уже неделю можно сказать мучаюсь, и всё никак, раз пять переустанавливал, то один совет послушаю, не выходит ни хрена, то другой, такая же хрень.
    Устанавливал когда то 16.04, устанавливал на ноутбук, тогда был подключен роутер + WI-FI у ноутбука, подключилось сразу на "УРА", без каких либо проблем.
    Теперь я устанавливаю проводное подключение, на простой компьютер, без роутера.
    Уже исписал пол тетради командами, толк нулевой, просмотрел кучу видео по данной теме, не получается всё равно (((
    Сейчас попробую скачать по новой образ и установить, если кто хочет подсказать, напишите пожалуйста как писать в терминале, с учётом пробелов, если они есть, а то с методами подбора уже устал.
    Заранее спасибо за помощь.
    P.S. За помощь заплатить не могу, из за отсутствия финансов, но обещаю, что первая моя статья на личном сайте, будет человеку, который помог решить данную проблему, контекстные ссылки будут приложены в обязательном порядке, без каких либо noindex nofollow, думаю админ сайта меня понял)
    вернулся, система у меня 64, памяти 32 гектара, проц Ксеон 2670, 8-16
    Удачи всем и только самого наилучшего настроения!



  • Для начала, надо понять видит ли система ваш сетевой адаптер, для этого надо выполнить команду в терминале:

    lspci | egrep -i --color 'network|ethernet'
    

    И прислать сюда результат команды.



  • Спасибо за ответ, вечером с дачи приеду обязательно попробую, и отпишусь, матери на даче помочь надо,это святое



  • ввёл я эту команду дважды, с SUDO и без
    lspci | egrep -i --color 'network|ethernet'
    ответ одинаковый
    05:00.0 Ethernet controller: Realtek Semiconducto Co., RTL 8111/8411/8411p
    CI Express Gigabit Ethernet Controller(rev07)
    Может не в тему, но установил Ubuntu по новой с Ubuntu RU. Или мне кажется, но отличия есть по сравнению с Ubuntu COM
    Сфоткал это дело, но фото получилось не очень, лучше фоткать когда солнце зайдёт, монитор бликует, а как скриншот сделать в Убунту я пока ещё не знаю+ сохранить



  • @SergTver это как раз, то что надо) теперь знаем какая у тебя сетевая карта, будет понятно в какую сторону копать, для решения проблемы)

    В общем есть два варианта решения, автоматический (но требует интернета) и в ручную.

    Попробуй каким-то образом, через вайфай брелок или через телефон по usb, получить интернет на компе.

    sudo apt-get install r8168-dkms
    

    Команда установит необходимый модуль для работы с твоей сетевой картой, если нет, напиши, попробуем другой вариант)
    И пришли вывод команды:

    dkms status
    

    Проблема скорей всего в том, что при установке, так как нет интернета, система не может подтянуть нужный ей модуль для сетевой карты.



  • @sergtver проверь ещё раз, правильно ты скопировал вывод команды?
    RTL 8111/8411/8411p - нет такой карты у realtek, есть RTL 8111/8168/8411



  • @hichnick интернет то у меня есть, в Винде проблем нет, перезагружаюсь на УБУНТУ, и не фига не работаеть, если можешь подскажи как в УБУНТУ сделать скриншот, и сохранить его, пришлю фотки, с фотика выходит плохо, так бы я все настройки прислал, в принципе там и есть то три вкладки(образно)
    Команды сейчас перепишу и выполню, результат пришлю, у меня на компе НЕТ WI-FI, напрямую через сетевую карту Материнки подключенно, роутер отключен, уже месяца два-три не пользуюсь очень круто режет скорость инета.
    8111/8411/8411p - проверю, ну у Хуанянев возможно всё )



  • Участник @hichnick написал в Не работает проводной интернет на Ubuntu 18.04:

    sudo apt-get install r8168-dkms

    ответ : не удалось найти пакет r8168-dkms
    И пришли вывод команды:
    dkms status
    ответ: sudo: dkms: команда не найдена

    на счёт 8411 P то всё верно я ошибся (
    понимаю, что нет дров под сетевуху ((, пойду гляну, что народ пишет по этому поводу



  • @sergtver попробуй подключит телефон через usb кабель и раздай с него интернет на комп. Если получится, выполни действия, описанные выше

    Если нет, пиши, подскажу как по другому сделать.



  • @hichnick с радостью бы сделал, но:

    1. Кабеля у меня к телефону никогда не было, если и подключался, то только когда был включен роутер.
    2. Подключить то могу, но не знаю, как действовать дальше, я интренетом в телефоне пользовался только для скачивания приложений на Гугл. На этом мои познания телефона закончены, не считая функции плеера)
      Вот такой я вот чудило )) Скоро 41, не научился до сих пор пользоваться телефоном в полном объёме)

    Скачал 8168, пытался запустить в Ubuntu, не смог. Каким файлом запускать то? Это не винда ) exe запустил и всё.

    Если включить роутер, возможно подключение нетбука, правда он греется как слон+ пол экрана не видно(матрица ту ту), но что то увидеть можно, но это надо тогда как то делать сеть или ещё что то, в чём я уж точно не петрю ни капельки (



  • Участник @hichnick написал в Не работает проводной интернет на Ubuntu 18.04:

    RTL 8111/8168/8411

    Если удалось скачать, то открываем терминал в том же месте где и скачанный файл:

    Разархивировать файл:

    tar xfvj 0010-r8168-8.045.08.tar
    

    Перейти в директорию:

    cd r8168-8.045.08
    

    Запустить скрипт автоустановки:

    sudo ./autorun.sh
    

    Должно быть что-то вроде этого:

    Check old driver and unload it.
    rmmod r8168
    Build the module and install
    At main.c:222:
    - SSL error:02001002:system library:fopen:No such file or directory: bss_file.c:175
    - SSL error:2006D080:BIO routines:BIO_new_file:no such file: bss_file.c:178
    sign-file: certs/signing_key.pem: No such file or directory
    Backup r8169.ko
    rename r8169.ko to r8169.bak
    DEPMOD 4.4.0-31-generic
    load module r8168
    Updating initramfs. Please wait.
    update-initramfs: Generating /boot/initrd.img-4.4.0-31-generic
    Completed.
    

    Проверить установку драйвера:

    lsmod | grep r8168
    


  • @hichnick Прежде всего Здравствуйте! И хочу сказать Тебе или Вам(не знаю, как лучше обратиться)
    ОГРОМНОЕ СПАСИБО, что Вы со мной возитесь.

    1. Я на счёт запуска, я так примерно и подумал )
    2. Боюсь, что первый и второй пункт у меня если и выйдет, то с огромным трудом.
    3. Думаю с Вами мы всё таки разберёмся в этой проблеме, Я буду вечный Ваш должник. Всё таки есть Бог на свете и добрые отзывчивые люди, которые готовы помочь суперновичку, да , да , именно СУПЕРНОВИЧКУ, который можно сказать делает первые шаги в Убунту.
      P.S. И как всегда не в тему, на Винде опять какой то косяк, так то я не геймер, играю редко, НО, позавчера, хотел отвлечься чуть чуть и поиграть, а вот и хрен, Винда обновилась и дрова моей Видюхи слетели, а устанавливаться не хотят не в какую, но с этим я вроде разобрался, ну можно сказать как то так. Итог, в игру не поирал, время убил на установку ну пока хоть как то так )
      И вообще скажу почему я очень хочу перейти на "Линя", есть очень много полезных для меня программ, которых на Винде просто нет, про игры молчу, вижу описание, скриншоты, как дело доходит до требований огромный жирный СТОП тут Линь, и заметил, что на ЛИНЕ больше игр, которые мне нравятся и я ждал 18.04, за это время нашел 100% замену программ, которыми я обычно пользуюсь, в планах за лето полностью перейти на Линя, 16.04 пользовался не много, понравилось, 18.04 сказать ПОЛЕТЕЛ это ничего не сказать.
      Ещё раз ОГРОМНОЕ СПАСИБО ЗА ПОМОЩЬ и самое главное
      НЕСКОНЧАЕМОЙ УДАЧИ И САМОГО НАИЛУЧШЕГО НАСТРОЕНИЯ!!!


  • вроде всё установилось, но без танцев не обошлось, из своих познаний ингиша, понял только, что, что то удалилось и что то установилось, одна строчка not found.

    Completed - я не увидил, но что то типа того что то есть
    Одним словом пакет вроде установился, возможно не до конца, но ставил не один раз, перезагружался не однократно (
    lsmod | grep r8168 эффект нулевой, пробовал по всякому.
    И ещё вопрос не в тему пакет net - tools???? у меня он не установлен по ходу, пакет то нашел, да не один, штук 6 какой ставить ума не приложу, про танцы с бубном расскажу подробнее, когда буду писать статью с контекстными ссылками на данный ресурс.
    Ещё добавил данную страницу на панель, как только что то новое появляется я в курсе, так удобнее, когда я в сети )



  • @sergtver все когда-то начинали своё знакомство с linux и в своё время были суперновичками)
    не у всех была возможность с кем-то проконсультироваться, русское сообщество по linux полно снобизма, так что надеюсь данный форум будет в силах помочь тем, кто только начинает своё знакомство с Ubuntu)

    По теме: можешь сделать скриншот вывода команды sudo ./autorun.sh?
    Для этого надо нажать кнопку на клавиатуре "print screen" и изображение сохранится в папке "Изображения".

    В принципе, самый простой вариант решения проблемы, это найти usb провод для смартфона (возможно от зарядки подойдёт), и подключить к компьютеру.
    Сейчас все смартфоны умеют раздавать интернет через usb подключение.

    Ввести команду:

    sudo apt update && sudo apt dist-upgrade
    

    Чтобы система загрузила все недостающие пакеты.

    P.S. Спасибо за отзыв! 😊



  • @hichnick все когда-то начинали своё знакомство с linux и в своё время были суперновичками)
    не у всех была возможность с кем-то проконсультироваться, русское сообщество по linux полно снобизма, так что надеюсь данный форум будет в силах помочь тем, кто только начинает своё знакомство с Ubuntu)

    Буду рад помочь чем смогу этому сообществу, в котором есть Ты и такие же как ТЫ, Я ТОЛЬКО ЗА ТАКИЕ СООБЩЕСТВА.

    1. Может мне по новой скачать и установить r8168 ?
    2. Когда я его скачал, то перенёс с флешки на Убунту, и так получилось, что он сохранился на раб.столе с расширением bz2,
      данная команда : tar xfvj 0010-r8168-8.045.08.tar его не открывала, распаковал вручную, опять на раб.стол, опять не открывает, думал думал, посмотрел read файл этого пакета, пришёл к выводу, что его куда то надо засунуть, искал куда, логическим путём куда то запихнул, попробовал снова, хрен. прибавил к команде BZ2 и открылось и распаковалось, и дальше всё как ТЫ написал пошло и поехало.
      Хоть я с Убунтой едва знаком, но она мне всё больше и больше нравится, интересно однако, даже очень интересно)
      НЕ в тему, я тут сижу напеваю, уже чуток придумал весёлую песенку про Убунту, время будет запишу и музыку и текст, вообще я думаю, если получится написать ГИМН УБУНТЫ, то подарю его Твоему сайту, если он конечно Тебе понравится.
      НО это не так быстро, я не пишу тексты на заказ, только, что в душе, так как вроде как близнец, то у меня 2 стороны - хорошая и не очень, но об этом потом.
      Живу один, надо проведать Мать, что то она простыла, может чего надо + самому надо в магазины пройтись, + посмотрю, может у неё шнур всё таки есть.
      А так могу подключить роутер и нетбук к нему через вай фай, а этот комп через провод от роутера, больше я пока ничего придумать не могу (
      Удачи и Огромного Несканчаемого Оптимизма.
      P.S. так что надеюсь данный форум будет в силах помочь тем, кто только начинает своё знакомство с Ubuntu)
      Я УВЕРЕН, ЧТО ТВОЙ ФОРУМ БУДЕТ ЛУЧШИМ и забудь слово надежда, я уверен и Ты будь уверен на все 100, как уверен я.
      Забей на всех кто говорит плохо, и делай им всем на зло свой форум, и тогда победишь, я прошёл многое и могу сказать забудь эти слова.
      Не надежда умирает последней, а вера в своё дело.
      У меня вчера был тоже случай, и я себе сказал, что я должен это сделать, даже через не могу, и сделал, дальше всё пошло как по маслу
      Ладно, а то я тут разговорился, а дела не делаются, ушел, всё сделаю (скриншоты и т.д.) отпишусь.☺


  • @hichnick Доброго времени суток!
    Скачивал, и танцевал с бубном и без, искал провод, нет провода, скачивал и что только не устанавливал и удалял, фоткал на фотик, плохо получается+сел сам фотик, стал делать скрины, сделал, оказалось, что прихватило второй монитор, устал как собак и ПОКА ЭФФЕКТ НУЛЕВОЙ (
    Начал опять всё сначала, закриншотил , сейчас попытаюсь выложить, мою деятельность) , улыбаюсь кстати уже идиотичеки)))
    это не пошло
    0_1525975153236_Снимок экрана от 2018-05-10 21-52-32.png
    пошло
    0_1525975237603_Снимок экрана от 2018-05-10 22-13-35.png
    надо было мне изначально делать скрины в Винде, сохранять на флешке, потом открывать уже в Убунту , а не переписывать от и до



  • На скриншотах видно, что уже усыновлена версия драйвера 8169. А мы пытаемся поставить 8168, что не верно и не нужно)
    И на скриншоте первом видно, что сеть вроде как живая)
    Появилась мысль, возможно что-то с проводом, которым подключается комп от роутера?

    Можно попробовать ещё переподключить модуль драйвера:

    sudo modprobe -r r8169
    sudo modprobe r8169
    

    Если не заработает, то

    sudo service network-manager restart
    

    Но я бы проверил кабель, сдаётся мне он косячный.



  • @hichnick Приветствую!

    1. Роутер у меня не подключен, просто есть возможность подключения
    2. У меня 2 системы, Винда и Линь, с Винды пишу, на Лине не могу подключиться.
    3. На Винде инет работает, отвечаю с Винды, перезагружаю комп и выбираю систему загрузки либо Линь либо Винда.
      Провод тут не при чём, я же его не выдёргиваю каждый раз.
      Что то наверное в настройках ввода данных , протоколы, ручное, автомат.,
      одним словом VPN и само подключение
      Попробую сделать снимок экрана, сохранить открыть в Лине и запустить, что Ты посоветовал. Отпишусь позже.

    Вот я и вернулся, не прошло и полгода)
    Скажу сразу через скриншоты гораздо быстрее

    ИТОГ

    0_1526065594128_Снимок экрана от 2018-05-11 23-36-23.png
    0_1526065643392_Снимок экрана от 2018-05-11 23-44-48.png

    Что значит skipping? Я так понимаю, что то пропустил с 1-20???



  • Получается дело не в драйверах и не в проводе.

    А на винде как у тебя подключение организованно? Через VPN или напрямую?

    Я изначально думал что подключаешься через роутер))
    Попробуй настроить роутер тогда и подключить через него комп, это проще всего.

    Если не получится, то покажу как VPN внутри Ubuntu настроить.



  • @hichnick Приветствую !
    Мне именно это наверное и надо, настроить подключение к интернету, через провод, который приходит в квартиру, без всяких роутеров(сильно режет скорость я от него пока отказался)
    Всякие маски сети, шлюз, адрес сетевой карты, DNS
    Я не знаю нужно ли вводить Ipv6, где что ставить на автомат, или на ручное, мне кажется главная запарка кроется именно тут.
    В Винде Ipv6 не ввожу, и всё работает.