Не работает проводной интернет на Ubuntu 18.04 провайдер Чайка.Net



  • Участник @hichnick написал в Не работает проводной интернет на Ubuntu 18.04:

    sudo apt-get install r8168-dkms

    ответ : не удалось найти пакет r8168-dkms
    И пришли вывод команды:
    dkms status
    ответ: sudo: dkms: команда не найдена

    на счёт 8411 P то всё верно я ошибся (
    понимаю, что нет дров под сетевуху ((, пойду гляну, что народ пишет по этому поводу



  • @sergtver попробуй подключит телефон через usb кабель и раздай с него интернет на комп. Если получится, выполни действия, описанные выше

    Если нет, пиши, подскажу как по другому сделать.



  • @hichnick с радостью бы сделал, но:

    1. Кабеля у меня к телефону никогда не было, если и подключался, то только когда был включен роутер.
    2. Подключить то могу, но не знаю, как действовать дальше, я интренетом в телефоне пользовался только для скачивания приложений на Гугл. На этом мои познания телефона закончены, не считая функции плеера)
      Вот такой я вот чудило )) Скоро 41, не научился до сих пор пользоваться телефоном в полном объёме)

    Скачал 8168, пытался запустить в Ubuntu, не смог. Каким файлом запускать то? Это не винда ) exe запустил и всё.

    Если включить роутер, возможно подключение нетбука, правда он греется как слон+ пол экрана не видно(матрица ту ту), но что то увидеть можно, но это надо тогда как то делать сеть или ещё что то, в чём я уж точно не петрю ни капельки (



  • Участник @hichnick написал в Не работает проводной интернет на Ubuntu 18.04:

    RTL 8111/8168/8411

    Если удалось скачать, то открываем терминал в том же месте где и скачанный файл:

    Разархивировать файл:

    tar xfvj 0010-r8168-8.045.08.tar
    

    Перейти в директорию:

    cd r8168-8.045.08
    

    Запустить скрипт автоустановки:

    sudo ./autorun.sh
    

    Должно быть что-то вроде этого:

    Check old driver and unload it.
    rmmod r8168
    Build the module and install
    At main.c:222:
    - SSL error:02001002:system library:fopen:No such file or directory: bss_file.c:175
    - SSL error:2006D080:BIO routines:BIO_new_file:no such file: bss_file.c:178
    sign-file: certs/signing_key.pem: No such file or directory
    Backup r8169.ko
    rename r8169.ko to r8169.bak
    DEPMOD 4.4.0-31-generic
    load module r8168
    Updating initramfs. Please wait.
    update-initramfs: Generating /boot/initrd.img-4.4.0-31-generic
    Completed.
    

    Проверить установку драйвера:

    lsmod | grep r8168
    


  • @hichnick Прежде всего Здравствуйте! И хочу сказать Тебе или Вам(не знаю, как лучше обратиться)
    ОГРОМНОЕ СПАСИБО, что Вы со мной возитесь.

    1. Я на счёт запуска, я так примерно и подумал )
    2. Боюсь, что первый и второй пункт у меня если и выйдет, то с огромным трудом.
    3. Думаю с Вами мы всё таки разберёмся в этой проблеме, Я буду вечный Ваш должник. Всё таки есть Бог на свете и добрые отзывчивые люди, которые готовы помочь суперновичку, да , да , именно СУПЕРНОВИЧКУ, который можно сказать делает первые шаги в Убунту.
      P.S. И как всегда не в тему, на Винде опять какой то косяк, так то я не геймер, играю редко, НО, позавчера, хотел отвлечься чуть чуть и поиграть, а вот и хрен, Винда обновилась и дрова моей Видюхи слетели, а устанавливаться не хотят не в какую, но с этим я вроде разобрался, ну можно сказать как то так. Итог, в игру не поирал, время убил на установку ну пока хоть как то так )
      И вообще скажу почему я очень хочу перейти на "Линя", есть очень много полезных для меня программ, которых на Винде просто нет, про игры молчу, вижу описание, скриншоты, как дело доходит до требований огромный жирный СТОП тут Линь, и заметил, что на ЛИНЕ больше игр, которые мне нравятся и я ждал 18.04, за это время нашел 100% замену программ, которыми я обычно пользуюсь, в планах за лето полностью перейти на Линя, 16.04 пользовался не много, понравилось, 18.04 сказать ПОЛЕТЕЛ это ничего не сказать.
      Ещё раз ОГРОМНОЕ СПАСИБО ЗА ПОМОЩЬ и самое главное
      НЕСКОНЧАЕМОЙ УДАЧИ И САМОГО НАИЛУЧШЕГО НАСТРОЕНИЯ!!!


  • вроде всё установилось, но без танцев не обошлось, из своих познаний ингиша, понял только, что, что то удалилось и что то установилось, одна строчка not found.

    Completed - я не увидил, но что то типа того что то есть
    Одним словом пакет вроде установился, возможно не до конца, но ставил не один раз, перезагружался не однократно (
    lsmod | grep r8168 эффект нулевой, пробовал по всякому.
    И ещё вопрос не в тему пакет net - tools???? у меня он не установлен по ходу, пакет то нашел, да не один, штук 6 какой ставить ума не приложу, про танцы с бубном расскажу подробнее, когда буду писать статью с контекстными ссылками на данный ресурс.
    Ещё добавил данную страницу на панель, как только что то новое появляется я в курсе, так удобнее, когда я в сети )



  • @sergtver все когда-то начинали своё знакомство с linux и в своё время были суперновичками)
    не у всех была возможность с кем-то проконсультироваться, русское сообщество по linux полно снобизма, так что надеюсь данный форум будет в силах помочь тем, кто только начинает своё знакомство с Ubuntu)

    По теме: можешь сделать скриншот вывода команды sudo ./autorun.sh?
    Для этого надо нажать кнопку на клавиатуре "print screen" и изображение сохранится в папке "Изображения".

    В принципе, самый простой вариант решения проблемы, это найти usb провод для смартфона (возможно от зарядки подойдёт), и подключить к компьютеру.
    Сейчас все смартфоны умеют раздавать интернет через usb подключение.

    Ввести команду:

    sudo apt update && sudo apt dist-upgrade
    

    Чтобы система загрузила все недостающие пакеты.

    P.S. Спасибо за отзыв! 😊



  • @hichnick все когда-то начинали своё знакомство с linux и в своё время были суперновичками)
    не у всех была возможность с кем-то проконсультироваться, русское сообщество по linux полно снобизма, так что надеюсь данный форум будет в силах помочь тем, кто только начинает своё знакомство с Ubuntu)

    Буду рад помочь чем смогу этому сообществу, в котором есть Ты и такие же как ТЫ, Я ТОЛЬКО ЗА ТАКИЕ СООБЩЕСТВА.

    1. Может мне по новой скачать и установить r8168 ?
    2. Когда я его скачал, то перенёс с флешки на Убунту, и так получилось, что он сохранился на раб.столе с расширением bz2,
      данная команда : tar xfvj 0010-r8168-8.045.08.tar его не открывала, распаковал вручную, опять на раб.стол, опять не открывает, думал думал, посмотрел read файл этого пакета, пришёл к выводу, что его куда то надо засунуть, искал куда, логическим путём куда то запихнул, попробовал снова, хрен. прибавил к команде BZ2 и открылось и распаковалось, и дальше всё как ТЫ написал пошло и поехало.
      Хоть я с Убунтой едва знаком, но она мне всё больше и больше нравится, интересно однако, даже очень интересно)
      НЕ в тему, я тут сижу напеваю, уже чуток придумал весёлую песенку про Убунту, время будет запишу и музыку и текст, вообще я думаю, если получится написать ГИМН УБУНТЫ, то подарю его Твоему сайту, если он конечно Тебе понравится.
      НО это не так быстро, я не пишу тексты на заказ, только, что в душе, так как вроде как близнец, то у меня 2 стороны - хорошая и не очень, но об этом потом.
      Живу один, надо проведать Мать, что то она простыла, может чего надо + самому надо в магазины пройтись, + посмотрю, может у неё шнур всё таки есть.
      А так могу подключить роутер и нетбук к нему через вай фай, а этот комп через провод от роутера, больше я пока ничего придумать не могу (
      Удачи и Огромного Несканчаемого Оптимизма.
      P.S. так что надеюсь данный форум будет в силах помочь тем, кто только начинает своё знакомство с Ubuntu)
      Я УВЕРЕН, ЧТО ТВОЙ ФОРУМ БУДЕТ ЛУЧШИМ и забудь слово надежда, я уверен и Ты будь уверен на все 100, как уверен я.
      Забей на всех кто говорит плохо, и делай им всем на зло свой форум, и тогда победишь, я прошёл многое и могу сказать забудь эти слова.
      Не надежда умирает последней, а вера в своё дело.
      У меня вчера был тоже случай, и я себе сказал, что я должен это сделать, даже через не могу, и сделал, дальше всё пошло как по маслу
      Ладно, а то я тут разговорился, а дела не делаются, ушел, всё сделаю (скриншоты и т.д.) отпишусь.☺


  • @hichnick Доброго времени суток!
    Скачивал, и танцевал с бубном и без, искал провод, нет провода, скачивал и что только не устанавливал и удалял, фоткал на фотик, плохо получается+сел сам фотик, стал делать скрины, сделал, оказалось, что прихватило второй монитор, устал как собак и ПОКА ЭФФЕКТ НУЛЕВОЙ (
    Начал опять всё сначала, закриншотил , сейчас попытаюсь выложить, мою деятельность) , улыбаюсь кстати уже идиотичеки)))
    это не пошло
    0_1525975153236_Снимок экрана от 2018-05-10 21-52-32.png
    пошло
    0_1525975237603_Снимок экрана от 2018-05-10 22-13-35.png
    надо было мне изначально делать скрины в Винде, сохранять на флешке, потом открывать уже в Убунту , а не переписывать от и до



  • На скриншотах видно, что уже усыновлена версия драйвера 8169. А мы пытаемся поставить 8168, что не верно и не нужно)
    И на скриншоте первом видно, что сеть вроде как живая)
    Появилась мысль, возможно что-то с проводом, которым подключается комп от роутера?

    Можно попробовать ещё переподключить модуль драйвера:

    sudo modprobe -r r8169
    sudo modprobe r8169
    

    Если не заработает, то

    sudo service network-manager restart
    

    Но я бы проверил кабель, сдаётся мне он косячный.



  • @hichnick Приветствую!

    1. Роутер у меня не подключен, просто есть возможность подключения
    2. У меня 2 системы, Винда и Линь, с Винды пишу, на Лине не могу подключиться.
    3. На Винде инет работает, отвечаю с Винды, перезагружаю комп и выбираю систему загрузки либо Линь либо Винда.
      Провод тут не при чём, я же его не выдёргиваю каждый раз.
      Что то наверное в настройках ввода данных , протоколы, ручное, автомат.,
      одним словом VPN и само подключение
      Попробую сделать снимок экрана, сохранить открыть в Лине и запустить, что Ты посоветовал. Отпишусь позже.

    Вот я и вернулся, не прошло и полгода)
    Скажу сразу через скриншоты гораздо быстрее

    ИТОГ

    0_1526065594128_Снимок экрана от 2018-05-11 23-36-23.png
    0_1526065643392_Снимок экрана от 2018-05-11 23-44-48.png

    Что значит skipping? Я так понимаю, что то пропустил с 1-20???



  • Получается дело не в драйверах и не в проводе.

    А на винде как у тебя подключение организованно? Через VPN или напрямую?

    Я изначально думал что подключаешься через роутер))
    Попробуй настроить роутер тогда и подключить через него комп, это проще всего.

    Если не получится, то покажу как VPN внутри Ubuntu настроить.



  • @hichnick Приветствую !
    Мне именно это наверное и надо, настроить подключение к интернету, через провод, который приходит в квартиру, без всяких роутеров(сильно режет скорость я от него пока отказался)
    Всякие маски сети, шлюз, адрес сетевой карты, DNS
    Я не знаю нужно ли вводить Ipv6, где что ставить на автомат, или на ручное, мне кажется главная запарка кроется именно тут.
    В Винде Ipv6 не ввожу, и всё работает.



  • Отлично, выяснили)
    Тогда смотри, поэтапно:

    • заходишь в настройки системы
      0_1526150343078_Снимок экрана от 2018-05-12 21-38-55.png

    • кликаем на плюсик напротив VPN
      0_1526150393645_Снимок экрана от 2018-05-12 21-39-24.png

    • выбираем "Тунельный протокол типа точка-точка (PPTP)
      0_1526150467724_Снимок экрана от 2018-05-12 21-40-56.png

    И вводим данные для подключения к провайдеру как на винде.
    Вкладки IPv4 и IPv6 оставляем как есть.



  • @hichnick Доброе Утро!
    Что такое NT-домен? Это Сервер авторизации???
    Где вводить адрес сетевой карты, DNS???
    Ладно, сейчас попробую, минут через 15, пока есть ещё дела в Инете.

    Не по теме: Тут смотрел Твой ресурс, хоть я и не геймер, но чуть стул не сломал во второй раз, глаза еле поймал, как увидел сколько игр под Линя, удивило количество.
    Нашёл программу аналог Иллюстратора, так Винда удалила закладку с обновлением системы, хорошо что Хром сохранил её где то там у себя.
    Найти бы ещё что то аналогичное Adobe Effect, нужна та в принципе только заставка для ютуб канала, но хочу сделать её имено в Убунту, покупать пока денег нет, да и самому куда интереснее.
    Смотрю у Тебя тоже хром есть, хороший браузер, мне нравится )
    Ах да забыл сказать, разница загрузки Винды и Убунту, это что то с чем то, я первый раз ощущаю разницу SSD и HDD, на Винде за целый год разницы не чувствовал, как только не настраивал. Даже на установленной с нуля. Винда - сходит в туалет, умылся, пришёл загрузилась. Убунту - включил, со стула привстал, приготовился идти, а уже всё, и самое интересное, что на любую вкладку нажимай и всё открывается, даааа, Винде до этого далеко. Сказать ракета ничего не сказать, скорость света однако, есть над чем "чепу" почесать )
    Ну ладно я перекурить, да попробую, по колдовать с подключением.



  • Участник @sergtver написал в Не работает проводной интернет на Ubuntu 18.04:

    Что такое NT-домен? Это Сервер авторизации???
    Где вводить адрес сетевой карты, DNS???

    Если у тебя VPN соединение, то достаточно ввести:

    • Адрес vpn сервера (шлюз)

    • Имя пользователя

    • Пароль

    Всё остальное, по типу DNS будет получено автоматически от провайдера.



  • @hichnick Пробовал и так и этак, не получается не как. Единственное, потом пробовал не автоматическое подключение, а ручное , уже не помню что точно выставлял, НО, VPN загорелся что включен, подключение тоже, но ничего не работает.
    Чуть позже попробую снова. Вот думаю "сфотать" всё как у меня есть и загрузить сюда, VPN отдельно, подключение отдельно.
    До того как придти на Твой форум, смотрел много видео, в каком то из них не подключался Автомат, там показывали как решить проблему, пробовал, не получилось, подумал там про 16.04, а у меня уже турболёт 18.04 )
    Попробую, но чуть позже. пока думаю в какой последовательности делать скриншоты.



  • @hichnick что то не получается (

    ввёл так

    0_1526231174793_Снимок экрана от 2018-05-13 21-28-16.png
    больше ничего не трогал, после неудач пробовал нажать на подключение, итог один, не работает (



  • Участник @sergtver написал в Не работает проводной интернет на Ubuntu 18.04:

    @hichnick что то не получается (

    Возможно не все данные, которые требует провайдер были введены.
    Пришли скриншот настроек интернет подключения в винде.

    Ещё заметил на скриншоте, что подключение 100мб/с было выключено. Пробовал включать?



  • @hichnick Доброе Утро! Пробовал по всякому, и так и сяк (
    попробую сделать скриншоты Винды, но чуть чуть позже, попытаюсь ещё раз всё сначала.
    Пока фотошоп установлю, paint не люблю, к сожалению, в своё время достал он меня. Пока буду устанавливать фотошоп.
    Нее, подумал, сделаю в paint
    Вернулся, сам не ожидал, вновь освоил paint )))
    если что не хватает напиши, и вообще огромное СПАСИБИЩЕ, другой бы плюнул на всё это дело, забил бы и послал бы учить мат часть )
    0_1526268718231_4.png
    ну как то так )

    подумал наделать скринов в убунту, все что возможно, склеить в paint? прислать сюда под номерами, так будет проще объянять где, что поменять.
    Я бы ссылки на ютуб кинул или видос вставил, но думаю нельзя так делать. А видео как человек показывает как решить данную проблему на 16.04, НО там network-manager удаляешь, устанавливаешь networking далее редактируешь через мне не известное NANO , НО не особо и выходит, то не сохраняется, то ещё что то.
    Одним словом показывает как настроить ручное и автоматическое. Я так понимаю DHCP это автоматическое.
    После всех этих проб я уже по новой ставил Линь раз шесть, это точно.Благо не долго )


Log in to reply