Иероглифы (ошибка кодировки) в текстовом редакторе Ubuntu 18.04



  • Друзья, привет!

    Очень понравилось начинание владельца сайта! Сам я, как полный нуб в Ubuntu, попробую описать решение очередной своей нубовской проблемы. А именно - иероглифы и крякозябры в текстовых файлах, которые создавались под Виндой. Для тех, кто также столкнулся с подобной проблемой и не нашел решения - привожу два варианта.

    Первый (и самый простой) - открываем терминал (Ctrl+Alt+T) и вводим в него команду

    gsettings set org.gnome.gedit.preferences.encodings candidate-encodings "['UTF-8', 'WINDOWS-1251', 'CURRENT', 'ISO-8859-15', 'UTF-16']"

    Все должно заработать.

    Если нет - пробуем ВТОРОЙ вариант:

    1. Устанавливаем Редактор Dconf (Ctrl+Alt+T) и команда
      sudo apt-get install dconf-tools
    2. Открываем редактор и, с его помощью, переходим в раздел /org/gnome/gedit/preferences/encodings/
      Там открываем единственный в директории файл.
    3. Переключаем ползунок "use default value"/"использовать стандартное значение" в выключенное положение и в ставшую активной строку вводим все так, чтобы получилось следующее:
      ['UTF-8', 'WINDOWS-1251', 'CURRENT', 'ISO-8859-15', 'UTF-16']
      Жмем подтвержающую галочку (при наличии) и проверяем работу;-)

    Надеюсь кому-то будет полезным:-) А автору ресурса - огромной удачи в развитии проекта!!)



  • @willy спасибо за вклад в сообщество, очень полезная и ценная информация, думаю многие сталкивались с такой проблемой.



  • @willy Спасибо, не знаю это или не это, НО, вчера при установки драйвера для видеокарты NVidia 1060-3, ответ был:
    Невозможно корректно установить из за бла бла бла, из всего я только понял, что что-то и чего-то не смогло прочитать, и связано это с кодировкой, попробую, наверное отпишусь только завтра.